import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RestApiUsernameToken Username=\"([^\"@]+)\", Domain=\"([^\"@]+){0,1}\", Digest=\"([^\"]+)\", Nonce=\"([^\"]+)\", Created=\"(\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2}Z)\"";
final String string = "RestApiUsernameToken Username=\"admin\", Domain=\"default\", Digest=\"+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40=\", Nonce=\"bfb79078ff44c35714af28b7412a702b\", Created=\"2016-04-29T15:48:26Z\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}