import Foundation
let pattern = #"RestApiUsernameToken Username="([^"@]+)", Domain="([^"@]+){0,1}", Digest="([^"]+)", Nonce="([^"]+)", Created="(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"RestApiUsernameToken Username="admin", Domain="default", Digest="+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40=", Nonce="bfb79078ff44c35714af28b7412a702b", Created="2016-04-29T15:48:26Z""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}