import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\s:,]+)(?#get field)\n"
+ ":[ ]*(?#get separator)\n"
+ "([^,\\{\\}\\n\\[\\]\\s][^,\\n]*)(?#get value)";
final String string = "{\n"
+ " field-1: \"field value 1\",\n"
+ " field2:\"field 2\",\"fieldThree\": \"value field param {three} \",\n"
+ " \"subobject\":{\n"
+ " \"subfield1\":1.1,\n"
+ " \"sub-field-2\":\"subval [1.2]\",\n"
+ " \"sub-subobject\":{\n"
+ " \"sub_subfield1\":\"sub sub field 1 ~\",\n"
+ " \"sub_subfield2\":\"sub sub field 2 !@#$%/\"\n"
+ " }\n"
+ " },\n"
+ " \"array\":[\n"
+ " { objectA:01, objectAA:02 },\n"
+ " { objectB:01, objectBB:02 }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}