const regex = new RegExp('([^\\s:,]+)(?#get field)
:[ ]*(?#get separator)
([^,\\{\\}\\n\\[\\]\\s][^,\\n]*)(?#get value)', 'g')
const str = `{
field-1: "field value 1",
field2:"field 2","fieldThree": "value field param {three} ",
"subobject":{
"subfield1":1.1,
"sub-field-2":"subval [1.2]",
"sub-subobject":{
"sub_subfield1":"sub sub field 1 ~",
"sub_subfield2":"sub sub field 2 !@#\$%/"
}
},
"array":[
{ objectA:01, objectAA:02 },
{ objectB:01, objectBB:02 }
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}