import Foundation
let pattern = ##"""
([^\s:,]+)(?#get field)
:[ ]*(?#get separator)
([^,\{\}\n\[\]\s][^,\n]*)(?#get value)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = ##"""
{
field-1: "field value 1",
field2:"field 2","fieldThree": "value field param {three} ",
"subobject":{
"subfield1":1.1,
"sub-field-2":"subval [1.2]",
"sub-subobject":{
"sub_subfield1":"sub sub field 1 ~",
"sub_subfield2":"sub sub field 2 !@#$%/"
}
},
"array":[
{ objectA:01, objectAA:02 },
{ objectB:01, objectBB:02 }
]
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)