using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] ""(\S+)\s?(\S+)?\s?(\S+)?"" (\d{3}|-) (\d+|-) (\S+) ""(\S+)"" ""(.+)"" ""-""$";
string input = @"66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] ""POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1"" 200 - missinglinksbrewery.com ""http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000"" ""WordPress/4.9.1; http://missinglinksbrewery.com"" ""-""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}