// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] "(\S+)\s?(\S+)?\s?(\S+)?" (\d{3}|-) (\d+|-) (\S+) "(\S+)" "(.+)" "-"$"#).unwrap();
let string = "66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] \"POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1\" 200 - missinglinksbrewery.com \"http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000\" \"WordPress/4.9.1; http://missinglinksbrewery.com\" \"-\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}