use strict;
my $str = '66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] "POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1" 200 - missinglinksbrewery.com "http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000" "WordPress/4.9.1; http://missinglinksbrewery.com" "-"';
my $regex = qr/^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] "(\S+)\s?(\S+)?\s?(\S+)?" (\d{3}|-) (\d+|-) (\S+) "(\S+)" "(.+)" "-"$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}