package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] "(\S+)\s?(\S+)?\s?(\S+)?" (\d{3}|-) (\d+|-) (\S+) "(\S+)" "(.+)" "-"$`)
var str = `66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] "POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1" 200 - missinglinksbrewery.com "http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000" "WordPress/4.9.1; http://missinglinksbrewery.com" "-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}