# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] \"(\S+)\s?(\S+)?\s?(\S+)?\" (\d{3}|-) (\d+|-) (\S+) \"(\S+)\" \"(.+)\" \"-\"$"
test_str = "66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] \"POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1\" 200 - missinglinksbrewery.com \"http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000\" \"WordPress/4.9.1; http://missinglinksbrewery.com\" \"-\""
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.