import Foundation
let pattern = #"^(\S+) (\S+) (\S+) \[([\w:\/]+\s[+\-]\d{4})\] "(\S+)\s?(\S+)?\s?(\S+)?" (\d{3}|-) (\d+|-) (\S+) "(\S+)" "(.+)" "-"$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"66.175.239.30 - - [01/Jan/2018:00:30:40 -0500] "POST /wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000 HTTP/1.1" 200 - missinglinksbrewery.com "http://missinglinksbrewery.com/wp-cron.php?doing_wp_cron=1514784640.8263568878173828125000" "WordPress/4.9.1; http://missinglinksbrewery.com" "-""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)