#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{9}$)(?=.*(\d).*\1)(?:\.*\d){1,9}\.*$"
Local $sString = "........." & @CRLF & _
" - false - no numbers repeated" & @CRLF & _
"123456789" & @CRLF & _
" - false - no numbers repeated" & @CRLF & _
"1.2.3.4.5" & @CRLF & _
" - false - no numbers repeated" & @CRLF & _
"1...3...5" & @CRLF & _
" - false - no numbers repeated" & @CRLF & _
"112345678" & @CRLF & _
" - true - number 1 is repeated" & @CRLF & _
"1......1." & @CRLF & _
" - true - number 1 is repeated" & @CRLF & _
"11244.56." & @CRLF & _
" - true - number 1 and 4 are repeated" & @CRLF & _
"234.5.6.4" & @CRLF & _
" - true - number 4 is repeated"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")