import Foundation
let pattern = #"^(?=.{9}$)(?=.*(\d).*\1)(?:\.*\d){1,9}\.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.........
- false - no numbers repeated
123456789
- false - no numbers repeated
1.2.3.4.5
- false - no numbers repeated
1...3...5
- false - no numbers repeated
112345678
- true - number 1 is repeated
1......1.
- true - number 1 is repeated
11244.56.
- true - number 1 and 4 are repeated
234.5.6.4
- true - number 4 is repeated
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)