re = /^(?=.{9}$)(?=.*(\d).*\1)(?:\.*\d){1,9}\.*$/m
str = '.........
- false - no numbers repeated
123456789
- false - no numbers repeated
1.2.3.4.5
- false - no numbers repeated
1...3...5
- false - no numbers repeated
112345678
- true - number 1 is repeated
1......1.
- true - number 1 is repeated
11244.56.
- true - number 1 and 4 are repeated
234.5.6.4
- true - number 4 is repeated'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end