const regex = /^(?=.{9}$)(?=.*(\d).*\1)(?:\.*\d){1,9}\.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{9}$)(?=.*(\\d).*\\1)(?:\\.*\\d){1,9}\\.*$', 'gm')
const str = `.........
- false - no numbers repeated
123456789
- false - no numbers repeated
1.2.3.4.5
- false - no numbers repeated
1...3...5
- false - no numbers repeated
112345678
- true - number 1 is repeated
1......1.
- true - number 1 is repeated
11244.56.
- true - number 1 and 4 are repeated
234.5.6.4
- true - number 4 is repeated`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}