import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{9}$)(?=.*(\\d).*\\1)(?:\\.*\\d){1,9}\\.*$";
final String string = ".........\n"
+ " - false - no numbers repeated\n"
+ "123456789\n"
+ " - false - no numbers repeated\n"
+ "1.2.3.4.5\n"
+ " - false - no numbers repeated\n"
+ "1...3...5\n"
+ " - false - no numbers repeated\n"
+ "112345678\n"
+ " - true - number 1 is repeated\n"
+ "1......1.\n"
+ " - true - number 1 is repeated\n"
+ "11244.56.\n"
+ " - true - number 1 and 4 are repeated\n"
+ "234.5.6.4\n"
+ " - true - number 4 is repeated";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}