using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{9}$)(?=.*(\d).*\1)(?:\.*\d){1,9}\.*$";
string input = @".........
- false - no numbers repeated
123456789
- false - no numbers repeated
1.2.3.4.5
- false - no numbers repeated
1...3...5
- false - no numbers repeated
112345678
- true - number 1 is repeated
1......1.
- true - number 1 is repeated
11244.56.
- true - number 1 and 4 are repeated
234.5.6.4
- true - number 4 is repeated";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}