# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?!\s|$)/. /g;t' <<< "What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string."