use strict;
my $str = 'What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string.';
my $regex = qr/\.(?!\s|$)/p;
my $subst = '. ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";