# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.(?!\s|$)"
test_str = "What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string."
subst = ". "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.