re = /\.(?!\s|$)/
str = 'What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string.'
subst = '. '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result