import Foundation
let pattern = #"\.(?!\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #". "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)