using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?!\s|$)";
string substitution = @". ";
string input = @"What is the clean way in python to do this simple text fixing - checking if every full stop (except the last one) is followed by space.Assume that having a dot not followed by an empty space is the only possible error we can get in the input string.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}