using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( +)(if|foreach|switch)((.*)\s+(//)(.*)|(.*?))\n( +)\{";
string substitution = @"$1$2$4$7 { $5$6";
string input = @" $key = trim($matches[0][$i], '[]');
if ($key === '') // Empty notation will return the value as array
{
break;
}
if (isset($value[$key]))
{
$value = $value[$key];
}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}