import re
regex = re.compile(r"( +)(if|foreach|switch)((.*)\s+(//)(.*)|(.*?))\n( +)\{", flags=re.MULTILINE)
test_str = (" $key = trim($matches[0][$i], '[]');\n"
" if ($key === '') // Empty notation will return the value as array\n"
" {\n"
" break;\n"
" }\n\n"
" if (isset($value[$key]))\n"
" {\n"
" $value = $value[$key];\n"
" }\n")
subst = "$1$2$4$7 { $5$6"
result = regex.sub(subst, test_str)
if result:
print(result)