$re = '~( +)(if|foreach|switch)((.*)\s+(//)(.*)|(.*?))\n( +)\{~m';
$str = ' $key = trim($matches[0][$i], \'[]\');
if ($key === \'\') // Empty notation will return the value as array
{
break;
}
if (isset($value[$key]))
{
$value = $value[$key];
}
';
$subst = "$1$2$4$7 { $5$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;