use strict;
my $str = ' $key = trim($matches[0][$i], \'[]\');
if ($key === \'\') // Empty notation will return the value as array
{
break;
}
if (isset($value[$key]))
{
$value = $value[$key];
}
';
my $regex = qr~( +)(if|foreach|switch)((.*)\s+(//)(.*)|(.*?))\n( +)\{~mp;
my $subst = '$1$2$4$7 { $5$6';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";