import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( +)(if|foreach|switch)((.*)\\s+(//)(.*)|(.*?))\\n( +)\\{";
final String string = " $key = trim($matches[0][$i], '[]');\n"
+ " if ($key === '') // Empty notation will return the value as array\n"
+ " {\n"
+ " break;\n"
+ " }\n\n"
+ " if (isset($value[$key]))\n"
+ " {\n"
+ " $value = $value[$key];\n"
+ " }\n";
final String subst = "$1$2$4$7 { $5$6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}