package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( +)(if|foreach|switch)((.*)\s+(//)(.*)|(.*?))\n( +)\{`)
var str = ` $key = trim($matches[0][$i], '[]');
if ($key === '') // Empty notation will return the value as array
{
break;
}
if (isset($value[$key]))
{
$value = $value[$key];
}
`
var substitution = "$1$2$4$7 { $5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}