#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)first(?:(?!and)[^;,.])*second"
Local $sString = "I would like it to match the following:" & @CRLF & _
"first some word second" & @CRLF & _
"" & @CRLF & _
"But not match the following:" & @CRLF & _
"" & @CRLF & _
"first . some word second" & @CRLF & _
"first ; some word second" & @CRLF & _
"" & @CRLF & _
"It is working but it is also excluding the following:" & @CRLF & _
"" & @CRLF & _
"blah ; first some word second"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")