import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "first(?:(?!and)[^;,.])*second";
final String string = "I would like it to match the following:\n"
+ "first some word second\n\n"
+ "But not match the following:\n\n"
+ "first . some word second\n"
+ "first ; some word second\n\n"
+ "It is working but it is also excluding the following:\n\n"
+ "blah ; first some word second";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}