$re = '/first(?:(?!and)[^;,.])*second/m';
$str = 'I would like it to match the following:
first some word second
But not match the following:
first . some word second
first ; some word second
It is working but it is also excluding the following:
blah ; first some word second';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);