using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"first(?:(?!and)[^;,.])*second";
string input = @"I would like it to match the following:
first some word second
But not match the following:
first . some word second
first ; some word second
It is working but it is also excluding the following:
blah ; first some word second";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}