const regex = /first(?:(?!and)[^;,.])*second/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('first(?:(?!and)[^;,.])*second', 'gm')
const str = `I would like it to match the following:
first some word second
But not match the following:
first . some word second
first ; some word second
It is working but it is also excluding the following:
blah ; first some word second`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}