use strict;
my $str = 'I would like it to match the following:
first some word second
But not match the following:
first . some word second
first ; some word second
It is working but it is also excluding the following:
blah ; first some word second';
my $regex = qr/first(?:(?!and)[^;,.])*second/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}