#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}"
Local $sString = "[{" & @CRLF & _
" "54ffe69-b8f6-47c8-9437-ccea8ecc2d77": {" & @CRLF & _
" "name": "ORC"," & @CRLF & _
" "$description": "Design polar from ORC"," & @CRLF & _
" "source": {" & @CRLF & _
" "label": "signalk-polar"" & @CRLF & _
" }," & @CRLF & _
" "polarData": [{" & @CRLF & _
" "trueWindSpeed": 3.086666667," & @CRLF & _
" "beatAngles": [" & @CRLF & _
" 0.738274274" & @CRLF & _
" ]" & @CRLF & _
" }]" & @CRLF & _
" }" & @CRLF & _
" }]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")