// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}").unwrap();
let string = "[{
\"54ffe69-b8f6-47c8-9437-ccea8ecc2d77\": {
\"name\": \"ORC\",
\"$description\": \"Design polar from ORC\",
\"source\": {
\"label\": \"signalk-polar\"
},
\"polarData\": [{
\"trueWindSpeed\": 3.086666667,
\"beatAngles\": [
0.738274274
]
}]
}
}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}