import re
regex = re.compile(r"[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}", flags=re.MULTILINE)
test_str = ("[{\n"
" \"54ffe69-b8f6-47c8-9437-ccea8ecc2d77\": {\n"
" \"name\": \"ORC\",\n"
" \"$description\": \"Design polar from ORC\",\n"
" \"source\": {\n"
" \"label\": \"signalk-polar\"\n"
" },\n"
" \"polarData\": [{\n"
" \"trueWindSpeed\": 3.086666667,\n"
" \"beatAngles\": [\n"
" 0.738274274\n"
" ]\n"
" }]\n"
" }\n"
" }]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")