using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}";
string input = @"[{
""54ffe69-b8f6-47c8-9437-ccea8ecc2d77"": {
""name"": ""ORC"",
""$description"": ""Design polar from ORC"",
""source"": {
""label"": ""signalk-polar""
},
""polarData"": [{
""trueWindSpeed"": 3.086666667,
""beatAngles"": [
0.738274274
]
}]
}
}]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}