const regex = /[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}', 'gm')
const str = `[{
"54ffe69-b8f6-47c8-9437-ccea8ecc2d77": {
"name": "ORC",
"\$description": "Design polar from ORC",
"source": {
"label": "signalk-polar"
},
"polarData": [{
"trueWindSpeed": 3.086666667,
"beatAngles": [
0.738274274
]
}]
}
}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}