using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]";
string input = @"Create a regex that will recognize valid non-temporary Canadian social insurance numbers (SIN). An SIN has nine digits in three groups of three separated by a hyphen. Temporary SINs start with a 9.
956-943-987
123-456-987
123456789
908764392
956 - 543 - 432
956 - 543 - 432";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}