const regex = /[0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]', 'gm')
const str = `Create a regex that will recognize valid non-temporary Canadian social insurance numbers (SIN). An SIN has nine digits in three groups of three separated by a hyphen. Temporary SINs start with a 9.
956-943-987
123-456-987
123456789
908764392
956 - 543 - 432
956 - 543 - 432`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}