// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]").unwrap();
let string = "Create a regex that will recognize valid non-temporary Canadian social insurance numbers (SIN). An SIN has nine digits in three groups of three separated by a hyphen. Temporary SINs start with a 9.
956-943-987
123-456-987
123456789
908764392
956 - 543 - 432
956 - 543 - 432";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}