import re
regex = re.compile(r"[0-9]", flags=re.MULTILINE)
test_str = ("Create a regex that will recognize valid non-temporary Canadian social insurance numbers (SIN). An SIN has nine digits in three groups of three separated by a hyphen. Temporary SINs start with a 9.\n\n"
"956-943-987\n"
"123-456-987\n"
"123456789\n"
"908764392\n"
"956 - 543 - 432\n"
"956 - 543 - 432")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")