#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:.+?;|\G).*?\KA(?=.*?;)"
Local $sString = "ABCD ABCD; ABCD ABCD; ABCD ABCD"
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)