$re = '/(?:.+?;|\G).*?\KA(?=.*?;)/m';
$str = 'ABCD ABCD; ABCD ABCD; ABCD ABCD';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;