const regex = /(?:.+?;|\G).*?\KA(?=.*?;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.+?;|\\G).*?\\KA(?=.*?;)', 'gm')
const str = `ABCD ABCD; ABCD ABCD; ABCD ABCD`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);