import Foundation
let pattern = #"(?:.+?;|\G).*?\KA(?=.*?;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ABCD ABCD; ABCD ABCD; ABCD ABCD"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)