re = /(?:.+?;|\G).*?\KA(?=.*?;)/m
str = 'ABCD ABCD; ABCD ABCD; ABCD ABCD'
subst = 'X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result