use strict;
my $str = 'ABCD ABCD; ABCD ABCD; ABCD ABCD';
my $regex = qr/(?:.+?;|\G).*?\KA(?=.*?;)/mp;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";